Moduł Mapa obiektowa Leica XML

Z C-Geo Wiki
Skocz do: nawigacja, szukaj

Wstęp

Wymagania konfiguracyjne

Oprogramowanie biurowe C-Geo

Moduł Mapa obiektowa Leica XML jest dodatkowym modułem do C-Geo, dostępnym dla użytkowników od dnia 6.05.2019 r., od wersji C-Geo 2019 v. 8.12.05.06. Do jego kompletnego działania zalecane jest posiadanie modułu Dziennik pomiarów satelitarnych RTK/RTN w celu ewentualnej edycji pomiarów satelitarnych. Ponadto, zalecane jest posiadanie modułu Aktualizacja mapy zasadniczej w formacie GML w celu eksportu wytworzonych obiektów mapy zasadniczej do GML.

Oprogramowanie terenowe Leica Captivate

Zasilenie modułu Mapa obiektowa Leica XML odbywa się poprzez proces kodowania punktów, linii, obszarów wraz z uzupełnianiem wymaganych atrybutów celem prawidłowej prezentacji danych w oprogramowaniu C-Geo.

Użytkownik razem z modułem Mapa obiektowa Leica XML otrzymuje dedykowaną listę kodów oraz wykaz kodów obejmujący zakresem szablon C-Geo Mapa zasadnicza 2015 dla oprogramowania terenowego Leica Captivate. Zalecanym jest, aby użytkownik posiadał zainstalowane oprogramowanie Leica Captivate w wersji 4.10 lub wyższej.

Zastosowanie

Moduł przeznaczony jest do współpracy z danymi pomiarowymi w formacie Leica XML uzyskanymi z instrumentów geodezyjnych Leica Geosystems z oprogramowaniem Captivate.

Odpowiednio pomierzone szczegóły terenowe wraz z atrybutami, przy imporcie do C-Geo są przetwarzane do postaci obiektowej, a po ewentualnej dalszej edycji w C-Geo, mogą być zapisane do GML zgodnego z przepisami w zakresie geodezji i kartografii w celu aktualizacji zasobu geodezyjnego i kartograficznego. Ponadto, moduł umożliwia eksport do formatu Leica XML danych mapy wektorowej utworzonej w C-GEO w celu np. tyczenia obiektów.

Przygotowanie środowiska do pracy, eksport pliku Leica XML z urządzenia oraz import pliku Leica XML do oprogramowania C-Geo

Oprogramowanie terenowe Leica Captivate

Krok 1
Personalizacja pracy oprogramowania Captivate (Krok ten wykonujemy jednorazowo. Ustawienia zostają zapamiętane w urządzeniu.) W celu uzyskania maksymalnej produktywności po implementacji listy kodów do oprogramowania Leica Captivate należy po raz pierwszy wykonać dedykowaną personalizację kodowania zgodnie z załączonym ekranem.

Ustawienia > Personalizacja > Kodowanie

Leica 01.PNG

Krok 2
Dołączenie listy kodów do obiektu. Podczas tworzenia nowego obiektu z zakładki Lista kodów należy wybrać dedykowaną listę.

Przydatny wideo poradnik: Tworzenie nowego obiektu

Film posiada napisy w j. polskim. W menu wideo proszę wybrać opcję napisów oraz w ustawieniach wybrać język polski.

Krok 3
Przygotowanie listy kodów do pracy. Dla wygody użytkownika nazwy kodów zostały odpowiednio dobrane i powinny zostać posortowane po ich nazwie.

Pomiar > Przejdź na zakładkę kodowanie > Rozwiń listę kodów (Naciśnij klawisz Enter na prostokącie z napisem <Brak> lub stuknij w to miejsce rysikiem) > Fn Sortuj > Nazwa kodu > OK

Krok 4
Praca z listą kodów. Przy pracy z kodami pomocne dla użytkownika mogą być wideo poradniki:

Kodowanie i praca z obiektami liniowymi (Podstawy)

Kodowanie i praca z obiektami liniowymi (Dodatkowe funkcje)

Przypisywanie wielu kodów do jednej pikiety (Multikodowanie)

Filmy posiadają napisy w j. polskim. W menu wideo proszę wybrać opcję napisów oraz w ustawieniach wybrać język polski.

Krok 5
Eksport pliku Leica XML. Personalizacja eksportu XML dla oprogramowania C-Geo (Krok ten wykonujemy jednorazowo. Ustawienia zostają zapamiętane w urządzeniu.)

Naciśnij klawisz Enter na obiekcie lub stuknij rysikiem w obiekt, z którego chcesz eksportować dane > Eksportuj dane > XML > FN Ustawienia > Zaznacz opcje jak na poniższych ekranach

Leica 02.PNG

Leica 03.PNG

Leica 04.PNG

Eksport pliku Leica XML z pozyskanymi danymi terenowymi.

Naciśnij klawisz Enter lub stuknij rysikiem w obiekt, z którego chcesz eksportować dane > Eksportuj dane > XML > Typ obiektu Punkty/Linie > Wypełnij szczegóły eksportu tj. miejsce zapisu i nazwa pliku > OK

Oprogramowanie biurowe C-Geo

Do wykonania prawidłowego importu pliku Leica XML konieczne jest założenie projektu z zachowaniem zasad właściwych dla map obiektowych tzn. należy wybrać odpowiedni szablon mapy (mapa_zasadnicza_2015 lub mapa_zasadnicza_2015_z_k1_1998) oraz zestaw kodów (Mapa zasadnicza 2015 lub Mapa zasadnicza 2015 z K1 1998). Dodatkowo należy wybrać odwzorowanie oraz numer TERYT (jeśli mapa obiektowa docelowo będzie przekazywana do ODGiK w formacie GML).

Najistotniejszy jest wybór szablonu mapy, ponieważ zagwarantuje nam on prawidłową stylizację mapy po imporcie oraz jest to jedyny parametr projektu, którego nie można zmienić w trakcie pracy. Zalecamy wybór szablonów z rozszerzeniem .zmp, ponieważ zakładanie mapy trwa zdecydowanie szybciej niż w przypadku szablonów z rozszerzeniem .sz.

Więcej o szablonach zmp.

1aa.PNG

Import pliku w formacie Leica XML możemy wykonać w programie w dwóch miejscach:

- przez menu Plik -> Import -> Mapa obiektowa Leica XML

2aa.png

- przez menu Narzędzia -> Mapa obiektowa Leica XML

3.png

W obu przypadkach pojawia się okno wyboru pliku, który wskazujemy i zatwierdzamy

3a.PNG

Podczas importu może pojawić się komunikat o zmianie kodu obiektów i pytanie, czy zastosować nową stylizację. Najlepiej zaakceptować przyciskiem Wszystko – w efekcie nastąpi stylizacja wszystkich obiektów pochodzących z importu zgodnie z Rozporządzeniem w sprawie bazy danych obiektów topograficznych oraz mapy zasadniczej z 2 listopada 2015 r.

4.PNG

Po zakończeniu importu powinien pojawić się komunikat Operacja zakończona. Dotyczy on importu części mapowej.

5.PNG

Dziennik pomiarów RTK/RTN

Po zakończeniu importu części mapowej importowane są obserwacje do modułu Dziennik pomiarów RTK/RTN – okno zadania zostaje automatycznie otwarte, o ile mamy zakupioną licencję na ten moduł. Wczytane dane możemy zapisać jako zadanie. Więcej o module.

7.PNG

Uwaga ! Bardzo ważne jest, aby przed importem został ustawiony układ współrzędnych. W innym przypadku nie zostaną zaimportowane obserwacje do modułu.

6.PNG

Tachimetria

W kolejnym etapie pojawia się okno transmisji tachimetrii z trzema zakładkami:

- zakładka Stanowiska, w której pokażą się stanowiska tachimetryczne, o ile były zapisane w pliku Leica XML. Stanowiska te możemy zaimportować — wybrane lub wszystkie.
- zakładka Transmisja, w której możemy wykonać bezpośrednią transmisję z instrumentu pomiarowego.
- zakładka Konwersja – pozwala na bezpośrednią konwersję stanowisk tachimetrycznych ze wskazanego pliku.

8.PNG

Stanowiska zostają zaimportowane do projektu jako zadania tachimetryczne, które możemy wczytać w menu Obliczenia -> Tachimetria. Więcej o tachimetrii.

9.PNG

10.PNG

Okno tabeli współrzędnych

Po zakończeniu importu oprócz danych w modułach obliczeniowych współrzędne oraz obiekty znalazły się w tabeli współrzędnych i na mapie. Do tabeli współrzędnych zostały zaimportowane pikiety wraz z numerami, współrzędnymi, wysokościami H, błędami mp i mh, metodą pomiaru oraz datą utworzenia i modyfikacji. Ponadto punkty, które zostały zakodowane w terenie otrzymały właściwe kody z Rozporządzenia o BDOT500 (. . . ) i – jeśli ich geometria jest punktowa zgodnie z przepisami – trafiły na konkretne warstwy. Punkty z kodem, których geometria nie może być punktowa (np. na rysunku poniżej z kodem BUBZ02 zostają przypisane do warstwy specjalnej pointsleica), zaś pozostałe pikiety bez kodu pozostają na warstwie zerowej.

11.PNG

Okno mapy. Mapa obiektowa.

W oknie mapy po imporcie powinniśmy zobaczyć zaimportowane obiekty mapy zasadniczej wraz z odpowiednią stylizacją. Dodatkowo obiekty te mają uzupełnione częściowo atrybuty w bazie danych – część z nich pozyskana jest z wypełnionych w kontrolerze Leica atrybutów obligatoryjnych i fakultatywnych, część jest uzupełniona automatycznie, gdy wynika to jednoznacznie z kodu kartograficznego obiektu.

Jeśli opracowanie ma zostać przekazane do ODGiK jako plik GML to operator powinien uzupełnić pozostałe wymagane atrybuty obiektów, których nie udało się pozyskać z pliku Leica XML.

12.PNG

12a.PNG

Uwaga ! Obiekty liniowe i powierzchniowe, których geometria jest nieprawidłowa w świetle prawa zostają zaimportowane na warstwy właściwe ze względy na ich kod wraz ze swoimi atrybutami, ale nie otrzymują stylizacji. Jest to wizualny sygnał dla operatora, że obiekty te należy przejrzeć i doprowadzić je do prawidłowej geometrii poprzez modyfikacje lub przerysowanie.

13.PNG

Po opracowaniu mapy można skorzystać z wygenerowania automatycznej redakcji obiektów. Wystarczy w Legenda kliknąć prawym klawiszem myszy na wybrany folder lub warstwę i wybrać Wstaw etykiety.

14.png

Pozostałe pomierzone punkty bez kodu lub z kodem, który nie ma swojego punktowego odpowiednika trafiają na warstwę, która pojawia się po imporcie – pointsleica. Dodatkowo powstaje warstwa featuresleica, na którą z kolei zostają zaimportowane obiekty liniowe i powierzchniowe, których nie udało się zidentyfikować zgodnie z Rozporządzeniem (. . . ).

15.PNG

16.PNG

Jeśli chcemy uzupełnić nasz pomiar o nowe obiekty zgodne z przepisami najlepiej kartować je przy użyciu narzędzia Edytor mapy obiektowej Więcej informacji na temat tworzenia mapy obiektowej do wydania w formacie GML na naszej Wikipedii oraz na kanale Youtube.

Eksport do pliku Leica XML

Mapę numeryczną (np. wektorową, ale niekoniecznie obiektową), która jest widoczna w oknie mapy i edytowana w C-Geo, np. po imporcie z formatów DXF, SHP lub utworzona od początku w C-Geo np. po obliczeniu punktów trasy drogowej, możemy wyeksportować do pliku Leica XML, a następnie wgrać do naszego kontrolera.

Plik można wyeksportować na dwa sposoby:

- przez menu Plik -> Eksport -> Mapa obiektowa Leica XML

17.png

- przez menu Narzędzia -> Mapa obiektowa Leica XML - > Eksport XML

18.png

Po wyborze eksportu dowolną opcją pojawia się okno wyboru nazwy i lokalizacji pliku Zapisywanie jako. . .

19.PNG

Następnie, po kliknięciu Zapisz pojawia się okno wyboru warstw do eksportu. Pod prawym klawiszem myszy są dostępne dodatkowe opcje wyboru warstw: 20.png

Następnie klikamy OK i wywoływany jest eksport. Po zakończonym prawidłowo eksporcie powinien pojawić się komunikat Operacja zakończona.

5.PNG

Import Pliku XML do oprogramowania terenowego Leica Captivate

Umieść plik z danymi w katalogu Data np. nośnika USB > Naciśnij klawisz Enter lub stuknij rysikiem w obiekt, do którego chcesz importować dane > Importuj dane z > XML > Opcja Import punktów, linii, łuków, układów współrzędnych i kodów punktów musi być zaznaczona > Wypełnij szczegóły importu tj. nazwa pliku i nazwa obiektu > OK

Przydatny wideo poradnik:

Import pliku w formacie XML

Filmy posiadają napisy w j. polskim. W menu wideo proszę wybrać opcję napisów oraz w ustawieniach wybrać język polski.